You can find out if your Chromebook is vulnerable to Meltdown

0
128

  • Google published a table on the Chromium Wiki detailing which Chromebooks are vulnerable to Meltdown.
  • The vulnerability makes it easier for certain malware to steal sensitive information.
  • Only a handful of Chromebooks are vulnerable to the bug.

If you are a Chromebook owner who is concerned about the Meltdown bug, Google published a list on the Chromium Wiki that details which devices are vulnerable, which are not, and which have been patched.

The good news is that not many Chromebooks are vulnerable to Meltdown.

Intel made waves last week announcing a fundamental flaw in its CPUs that allows malware to steal sensitive data like passwords, cryptographic keys, and banking information from memory previously previously inaccessible. Security researchers soon found there were two vulnerabilities at play: Meltdown, which affects mainly Intel processors, and Spectre, a collection of variants that affects Intel, AMD, and ARM chips, among others.

Google’s Meltdown table has columns for the kernel version, architecture, and more. What you want to pay attention to is the “CVE-2017-5754 mitigations (KPTI) on M63?” column. If the table says “Yes” or “Not needed,” then your Chromebook is fine. If the table says “No,” your Chromebook will need an update to rectify that.

Editor’s Pick

related article

‘Spectre’ and ‘Meltdown’: New CPU vulnerabilities affect most smartphones and computers

Christiaan Colen The tech industry has been all a buzz over the last 48 hours with talk about a fundamental flaw in Intel’s CPUs that makes it easy for malware to steal sensitive data …

Finally, if the table says “EoL,” which is end-of-life, then your Chromebook will not receive an update since it is no longer supported.

What is good to see is that only five devices on the list reached EoL status, with just about every other Chromebook either checked off as “Yes” or “Not needed.” In other words, unless you own a much older Chromebook, you should be fine.

Apart from checking out the complete table, you can go into “chrome://gpu,” then take a peek at the “Operating System” row in the table marked “Version Information.” If your Chromebook runs versions 3.18 or 4.4 of the Linux kernel, your device is safe against Meltdown.

Spectre is a bit trickier to protect against, but as Android Police points out, you can turn on Chrome’s optional Site Isolation feature by switching the #enable-site-per-process flag to “Enabled.” You can copy and paste the link into Chrome’s address bar to enable the flag.

via Android Authority

January 11, 2018 at 11:54AM